Solving the Annoying Flashing Input Menu on Insignia Televisions

My blog is usually about other things, but I have occasionally been able to offer useful technical advice. My solution to the problem of experiencing a black screen after login on Windows Vista remains one of the most viewed entries of all time on this blog.

(My post on the most effective squirrel baffle of all time has not gotten nearly as much attention – even though it is free!)

Anyway, I own an Insignia flatscreen TV – not a large one – and for some time it has had an annoying glitch that I learned, when searching online, others have also experienced. The input menu – i.e. the menu that lets you choose input from DVD, HDMI, VGA, etc. – would just appear on the screen, sometimes flashing on and off, sometimes staying there for a few seconds before going away, sometimes doing any or all of the above for long enough for it to interfere with what I was doing.

Today I fixed it, eliminating the problem, hopefully forever. And so I wanted to share the solution.

When I looked online, I found only two suggestions other than “Take it back to the store for repairs” and since it is not an expensive television, that would be liable to cost enough to make it preferable to buy a new one. I am actually using this TV as a monitor on my computer, and I wanted to see if I can keep it working. When it is your computer monitor, having an annoying menu pop up frequently and at random is at least as irritating as when it happens when you are watching a show.

One suggestion was that it could have something to do with the remote control, especially if its batteries were running out. I quickly eliminated that as the source of the problem.

The other suggestion was that it had to do with the panel with buttons on the side of the TV. This was confirmed as the source of the problem when I discovered that, when I pushed the “power off/on” button, I would sometimes get the input menu rather than the result I was expecting. Clearly something was amiss with the buttons.

The suggestion was to clean the contacts, but since buttons on a television are really a redundant feature in our day of remote controls, I decided to do something more drastic but much more likely to work. I removed the button circuit altogether. And since then, the input menu has not appeared.

Here’s how I did it. This should not take more than 5-10 minutes.

First, disconnect the TV from the power, and lie the TV down face down flat on a soft surface. A couch works, since you can have the base stand sticking off – just remember to dust it before you do that.

Second, remove all the screws from the back. There are around 10 including those from the base stand, and they all should come out fairly easily.

Next, use a screwdriver to gently separate the front edge cover from around the TV screen itself. This is really the last thing preventing you from getting at the circuit that is causing your grief. It does not come apart without inserting a screwdriver, and you don’t want to apply so much force as to break something. It is a matter of a plastic cover that snaps into place, and so you will need to work your way around the TV with the screwdriver, angling it until the next snap is undone, and then next, and the next, until you can separate the front edge cover.

At this point, you should be able to get beneath the power, input, channel and volume buttons which are on the side of the TV. Beneath the black cover panel with the buttons, you will find a small circuit board with buttons in it. While you are welcome to try cleaning its contacts (someone recommended using alcohol), I simply removed it. I unplugged the power connector and took the circuit board out in its entirety, using some masking tape so as to not leave the power connector rattling about loosely inside the TV. I then put the cover with the buttons back, so as not leave an empty space there, snapped the front panel back, replaced the screws and screwed them in, and reconnected it to the power (and in my case to the computer, since I’ve been using it as a monitor).

The input menu has not popped up since.

Now of course you will need to rely on the remote control for turning the TV on and off, changing the channel, and lowering or raising the volume. Can I safely assume that most people were doing that with the remote anyway?

I should add as a disclaimer that I am not an expert in repairing televisions, and am in no way responsible or liable if your own experience in attempting to fix your TV is different than mine. I am simply sharing my own experience. You must use your own judgment when evaluating your own skill in carrying out the procedures describes, and dealing with any differences that might exist between your TV and mine or the problem affecting your TV vs. mine.

If the solution I described in this blog post worked for you, please leave a comment to let me know. And if other models than mine are different in some way, and so you had to tweak how you implemented this solution, why not leave a comment so that others can benefit from your insight?

  • thepoint2012

    rationalresponders.com/forum/32697

    youtube.com/watch?v=s3lwG4MytSI

    one applicant right here…

    get the POINT, Randi….

  • KG

    Thanks!! I have a 46 in with same problems. Tried several times other methods but yours worked. Left board in there to have a backing to allow buttons to stay out. Just disconnected wiring for both ends and used electric tape. Saved hundreds of dollars!

  • Brian W

    I have a 47″ with the channels changing constantly. I tried your method and it worked just fine. The TV has been running now for about an hour, and no probs.

  • dr who

    didnt work for me. thanks for the help though.

  • Paul

    Thanks! I was just about to buy a new main board when I read ur post. Did exactly as u suggested and unplugged power strip, problem solved. I concur, no need for direct buttons when all we use is remote. Worked like a charm, 52″ insignia LCD.

  • suzieq

    It worked on my 19 inch. I refused it throw it away!
    THX

  • je

    Cleaned the contacts, it worked.

  • Weekofmondays

    This would work, except that my remote stopped working and the universal remote won’t work for all of the features, and things like changing from the bluray player (hdmi) and over the air tv….

    • http://www.patheos.com/blogs/exploringourmatrix/ James F. McGrath

      What a pity. I take it it doesn’t have an “input” button, or at least, not one that works with the TV?

  • akshon

    took me an hour, but I unplugged the input button panel on the tv after removing the back screws and bending it enough to reach back there and pull it out. Tv works perfectly now…I guess those panels only last a few years before they go turbo!!! :)

  • auntie p

    Thanks – we followed your instructions and disconnected the power supply to the buttons on the side, worked a treat! Ours is a bush Tv btw. Thanks again!

  • R&R

    Thank you so much! It worked like a charm. I just unplugged the circuit board and taped off the wire instead of removing it. You’re a genius!

  • Charlie

    Sweet fix! 36″ Insignia. The hardest part was unsnapping the back cover, but after that, it was a breeze. You, sir, are a genius! My sincere thanks to you.

  • AMORPR

    Thank you so much……i did it and the input flasing went away…..A+

  • Qlidnaque

    i have 40 inch insignia tv that i’m also using for my monitor. The input menu popping up gradually got worse and more frequent so today i popped open the lid like instructed, and instead of removing the chip, i just cut the blue and white cord connecting the manual buttons to the motherboard. problem solved. :)

  • Guy

    Thank you!

  • SCOTT HEWITT

    Nope didn’t work for me but mine started after a thunder storm. The cable box hdmi stopped working and the tv started this crap.

  • Nits

    Thanks a lot. Exactly the same issue on my Bush HD ready. Detached the cable from side control buttons and no more switching the sources. Saved me from buying a new TV, just that now I have to rely on remote. Anyway, I dont remember ever going to the tv to change the channel.

  • Shayna

    Thank you so much!! This just worked on my Insignia 46′. It was the Settings menu that kept popping up. Followed your instructions and hasn’t happen for almost an hour.

  • SO

    Now does this work with all television sets. Because I have a Seiki 32″ flat screen and the input menu comes up and goes away every 5-10 seconds. And it gets anoying.

  • Linda

    Hi, Just finished following your suggestion on my 2 yr old 32″ Westinghouse LCD. So far it worked. Couldn’t completely remove the back so it ended up being a 2 person job. All I had to do was unplug power source. Thanks!


CLOSE | X

HIDE | X